今天在运维阿里云服务器的时候,在阿里云安全中心管理控制台发现有一项漏洞风险提示为:RHSA-2018:3157-中危: curl 和 nss-pem 安全和BUG修复更新。在详细信息描述中可以看到漏洞涉及到:libcurl 信息泄露漏洞、curl 缓冲区错误拒绝服务漏洞、curl存在拒绝服务漏洞、curl 缓冲区错误漏洞、curl:当缺少 RTSP headers时,越界读取的堆允许拒绝服务的信息泄漏。

开该漏洞风险详情信息后,可以查看到漏洞详情信息以及受影响的ECS服务器实例信息,如下图:

可以从漏洞详情中查看到如下具体信息:

漏洞编号

影响分  

漏洞公告

CVE-2018-1000007

9.8

libcurl 信息泄露漏洞

CVE-2018-1000120

9.8

curl 缓冲区错误拒绝服务漏洞

CVE-2018-1000121

5.3

curl存在拒绝服务漏洞

CVE-2018-1000122

9.1

curl 缓冲区错误漏洞

CVE-2018-1000301

5.4

curl:当缺少 RTSP headers时,越界读取的堆允许拒绝服务的信息泄漏


在截图中的阿里云漏洞详情下面有列举出受到影响的阿里云ECS服务器实例信息,在实例列表中可通过阿里云官方提供的修复功能进行修复。