在C#语言的WinForm窗体程序中,有时候我们需要切换WinForm窗体程序项目的.NET Framework版本号,例如从.NET Framework 4.5版本切换到.NET Framework 4.0版本等,从高版本切换到低版本需要注意兼容性,有可能高版本中的有些语法以及封装方法在低版本中无法找到而导致程序错误。

下面以Visual Studio 2017中的Winform项目切换.Net Framework版本号为例,具体操作如下:

(1)选中Winform项目的项目根文件,然后右键,我们可以看到有个属性菜单,如下图:

(2)进入属性页面后,在应用程序的设置页面,我们可以看到有个设置项为目标框架,在目标框架中将.NET Framework 4.5版本调整为.NET Framework 4.0版本,注意如果程序代码中使用到了.NET Framework 4.5版本独有的语法或者方法等,调整为低版本后程序将会抛出异常。